In order to fulfill the basic functions of our service, the user hereby agrees to allow Xiaomi to collect, process and use personal information which shall include but not be limited to written threads, pictures, comments, replies in the Mi Community, and relevant data types listed in Xiaomi's Private Policy. By selecting "Agree", you agree to Xiaomi's Private Policy and Content Policy .
Agree

Redmi Note 3

[Discussion] Not receiving real time whatsapp messages

2016-07-02 03:12:56
4935 11
I'm having problems receiving whatsapp messages as & when they're actually sent by others. Happens in both cases - when whatsapp in in the foreground as well as when it's in the background. It's only when i open a friend's chat screen that their messages get delivered, even when they've sent them hours ago. Any solution? Thanx in advance.
I'm using RN3SD 16 GB
2016-07-02 03:12:56
Favorites2 RateRate

Rookie Bunny

i.veddayma | from mobile

#1

Goto security->permission->auto-start-> enable WhatsApp and bingo!
2016-07-02 23:48:17
As the above user said follow the steps.
2016-07-03 02:59:20
Mi4i and Redmi Note 3 Global Beta Tester.....

Advanced Bunny

enam Author | from mobile

#3

i.veddayma
Goto security->permission->auto-start-> enable WhatsApp and bingo!

Thanx. Will try that n reply back.
2016-07-03 03:26:51

Advanced Bunny

enam Author | from mobile

#4

enam
Thanx. Will try that n reply back.

It's already set to auto start.
2016-07-03 03:28:20
enam replied at 2016-07-03 12:58 PM
It's already set to auto start.

Hi Bro,

Try this option :
Go to Setting - Installed Apps - WhatsApp - Show notification - and enable all the options there.

Let us know  if issue resolved or not.
2016-07-03 04:20:53

Advanced Bunny

enam Author | from mobile

#6

SumUp
Hi Bro,

Try this option :

Still not working bro.
2016-07-04 00:33:38
Edited by DEZIRABLE JAVI at 2016-07-07 01:58 PM

Hello,

Try these steps this one will surely help you,

First of all Go to security app

Then press permissions
Then you will see something like Autostart , Permission and install via Usb , simply press again on permissions,

There you will see all apps and on the top there is an
option permissions press that again , after pressing that you will see lot of options simply scroll down to the bottom there is an option " Display Pop-Up window" enter in that option find whatsapp and enable pop up window ,
I hope your issue will be resolved.
If the above procedure helps you please revert back and do rate my Reply.
Thanks

2016-07-07 04:18:48

Pro Bunny

Anmol0404 | from mobile

#8

The reason for it might be that you have restricted the permission to whatsapp for autostart, go into security then in permissions then autostart and enable whatsapp to restart and in permission enable pop up window and then you'll hwt real time whatsapp messages
2016-07-08 15:30:18
The Creator ANMOL

Master Bunny

Sanuj Bhatia | from mobile

#9

Yeah this happens with mee too... just lock whatsapp (keep it in the memory) and then it will work just fine...
2016-07-09 03:14:32


Join Our Channel: http://goo.gl/A6dT58
Please go to battery-manage battery performance and see if its turned off or on. If its turned on you will face this delayed notification. either choose whatsapp in the choose apps to removeit from battery manage or turn off the option totally.
2016-07-13 04:19:39
Proud Mi Fan
please sign in to reply.
Sign In Sign Up

enam

Advanced Bunny

  • Followers

    0

  • Threads

    3

  • Replies

    34

  • Points

    415

Lucky Draw No.

Read moreGet new
Copyright©2010-2020 Xiaomi.com, All Rights Reserved
Content Policy
Quick Reply To Top Return to the list