HDMI 2.0 is working, please make sure you have turned off HDMI Control under CEC. You can find this under Settings  Inputs  CEC  HDMI Control.
Once this is turned off, connect your 4K Device through any of the HDMI port and once you are in that device's display, click the centre button of the TV Remote, and you will see TV OPTIONS. Go to Settings in that  Device Settings  HDMI 2.0 and enable it. After this your device will recognise the TV as a 4K HDR Capable 60 FPS display.
Enjoy the 4K.
In my case the connected device is a PS4 Pro.