yes I need to to Oreo update