In order to fulfill the basic functions of our service, the user hereby agrees to allow Xiaomi to collect, process and use personal information which shall include but not be limited to written threads, pictures, comments, replies in the Mi Community, and relevant data types listed in Xiaomi's Private Policy. By selecting "Agree", you agree to Xiaomi's Private Policy and Content Policy .
Agree

Redmi Note 4

[ROM] Proximity sensor not working during call in RN4

2019-01-16 12:52:48
2614 12
After miui10 update, the proximity sensor is not working only during calls. I have checked with CPU-X app where it works perfectly fine(attached below). And in lock screen (with pocket mode enabled) also proximity sensor works fine. So definitely it's an software bug (upto my knowledge). Please fix this issue. Thanks in advance.Redmi Note 4 MIUI 10.1.1.0 stable
Single Poll thread Total 85 Users Voted
 
78.82% (67)
 
21.18% (18)
Submit
2019-01-16 12:52:48
Favorites1 RateRate

Master Bunny

Karthik_20 Author | from Redmi Note 4

#1

Working in pocket mode turned on
2019-01-16 12:58:42

Master Bunny

Karthik_20 Author | from Redmi Note 4

#2

Working on poket mode
2019-01-16 12:59:28

Advanced Bunny

1668472256 | from Redmi Note 4

#3

clear cache and reboot the phone
2019-01-16 21:29:49

Rookie Bunny

1733412378 | from Redmi Note 4

#4

actually in call apps some setting is available for inable
2019-01-17 08:34:39

Rookie Bunny

1733412378 | from Redmi Note 4

#5

follow these steps to enable proxy sensor
2019-01-17 08:50:44

Master Bunny

Karthik_20 Author | from Redmi Note 4

#6

1733412378
follow these steps to enable proxy sensor

thanjs for ur rply. but it's already in on state
2019-01-17 08:53:47
Karthik_20 replied at 2019-01-17 19:23:47
thanjs for ur rply. but it's already in on state

Hi,
Disable it as stated by above user - reboot the device- enable again.
2019-01-21 21:55:33

Rookie Bunny

anurag.anshuman.90 | from Redmi Note 4

#8

First go to call settings>incoming call settings then turn off proximitg sensor
Then reboot your device and then turn on the proximity sensor
2019-02-06 11:27:55

Rookie Bunny

Anirudh Raghu | from Redmi Note 4

#9

Sir...
Can you tell how to trigger it in the Lockscreen.
As it is a little bit tough to check it through Pocketmode, We can very well check it through WhatsApp call. It's working fine during a WhatsApp call. Sir, please check it and give your view.
Thank You.
2019-02-08 23:50:12

Rookie Bunny

Anirudh Raghu | from Redmi Note 4

#10

anurag.anshuman.90
First go to call settings>incoming call settings then turn off proximitg sensor
Then reboot your de ...

Sir...
I have done rebooting 4 to 5 times to make it work as your said.
But unfortunately, after a day or 2 days, the Proximity Sensor Stops working during Calls.
Anybody try to get this to the knowledge of Developers. So that they may try to fix it by the next System update.
Thank You.
2019-02-08 23:54:19
please sign in to reply.
Sign In Sign Up

Karthik_20

Master Bunny

  • Followers

    27

  • Threads

    50

  • Replies

    446

  • Points

    5198

3 Days Check-In
7 Days Check-In
21 Days Check-In
40 Days Check-In
New Home
2 million registered members
Mi Community Updater
April Participation
The Motivator
MIUI 8th Anniversary
10 Million Downloads
Throwback With Mi 2018
Xiaomi's 9th Birthday

Read moreGet new
Copyright©2016-2019 Xiaomi.com, All Rights Reserved
Content Policy
Quick Reply To Top Return to the list